SkyBlock Joining Issues

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 12:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2025 - 11:34 EDT

Investigating

We are currently investigating an issue with players not always being able to join SkyBlock.
Posted Apr 17, 2025 - 11:22 EDT
This incident affected: Minecraft Server Games (SkyBlock).